Database connectivity issue
Incident Report for Telerivet
Resolved
Telerivet has not detected any further issues with database connectivity or data integrity, and has verified that no scheduled messages or other data were lost due to this issue.
Posted May 23, 2021 - 03:47 UTC
Monitoring
The issue was caused by a corrupted database table storing scheduled messages and other scheduled events, which caused the database server to crash when triggering scheduled events. The corrupted database table has been repaired, and scheduled messages are being sent now. All Telerivet functionality should be working normally.
Posted May 22, 2021 - 14:39 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 22, 2021 - 14:32 UTC
Identified
The issue has been identified as a particular query causing Telerivet's database server to crash. Telerivet has disabled scheduled message functionality to avoid this issue and is continuing to investigate the issue.
Posted May 22, 2021 - 13:56 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2021 - 13:41 UTC
Investigating
Telerivet is currently investigating an issue with database connectivity.
Posted May 22, 2021 - 13:41 UTC
This incident affected: Web Dashboard and REST API.